Openwrt x86 установка на pc zhitsoboy.ru

Openwrt x86 установка на pc

OSBoy notes.

Записки обо всём.

Установка OpenWrt на виртуальную машину

Настало время опробовать свежий релиз OpenWRT 15.05 Chaos Calmer. А заодно я решил затестить, каково это — OpenWRT на x86 архитектуре, т.к. Линукс под рукой время от времени бывает нужен — для всяких экспериментов, ну или, хотя бы, флешку отформатировать для роутера. 🙂 Раньше я для этого использовал ноут с ArchLinux-ом. Но ноут у меня накрылся, да и Arch я разлюбил, после того как он на systemd перешёл. как то лень его фактически с нуля по новой осваивать! Зато для этих целей прекрасно подойдёт виртуалка с уже полюбившимся мне OpenWRT!

Подготовка ПО
Качаем последнюю стабильную версию VirtualBox (на момент написания статьи — 5.0.6) и соответствующую версию Extension Pack для него. Устанавливаем VirtualBox и Extension Pack. В моём случае — на компьютере установлена Windows 7 64bit — она и будет использоваться как Хост-ОС.
Качаем образ OpenWRT. Тут выбираем нужный релиз, затем архитектуру x86 (либо x86/64, как я, собственно, и сделал в данном случае) и, наконец, нужный образ (в данном случае — openwrt-15.05-x86-64-combined-ext4.img.gz). Если есть готовый образ для VirtualBox (.vdi) — скачиваем его. Если же доступен только raw образ (.img.gz), то его потребуется переконвертировать в совместимый с VirtualBox формат. Для этого воспользуемся встроенным в VirtualBox конвертором. В папке с установленной VirtualBox создаём текстовый файл с расширением .bat или .cmd следующего содержания: «%

dp0VBoxManage.exe» convertfromraw —format VDI %1 «%

dpn1.vdi»
pause Затем распаковываем образ из скачанного архива и перетаскиваем его на созданный ранее скрипт. Полученный .vdi образ можно подключать к Виртуальной машине.

Создание виртуальной машины (ВМ)
Запускаем VirtualBox и жмём «Создать». Задаём имя, тип и версию гостевой системы:

На этапе подключения жёсткого диска выбираем «Использовать существующий виртуальный жёсткий диск» и подключаем наш .vdi образ с OpenWRT:

Затем Выбираем созданную ВМ и жмём «Настроить». На вкладке «Сеть» настраиваем сетевой интерфейс для связи ВМ с внешним миром. Мой хост-компьютер подключен к домашней сети и интернет через роутер. Поэтому удобнее всего для ВМ будет использовать тип подключения «Сетевой мост». Таким образом ВМ будет выглядеть в сети как отдельное устройство: будет иметь возможность общаться с другими устройствами в домашней сети (включая хост-компьютер), выходить в интернет, получать от роутера IP адрес по DHCP и т.д.

Здесь «Realtek PCIe GBE Family Controller» — это физический интерфейс хост-машины, подключенный к роутеру, через который будет организован «сетевой мост».

На вкладке «COM-порты» нужно обязательно поставить галочку «Включить последовательный порт», иначе OpenWRT не сможет запуститься.

Запуск ВМ и настройка сети
Запускаем созданную виртуальную машину. После окончания процесса загрузки нажимаем Enter — станет доступна консоль OpenWRT.

Создаём пароль для root: passwd По умолчанию OpenWRT использует на lan интерфейсе статический адрес 192.168.1.1 . Чтобы настроить ВМ для работы в нашей домашней сети, редактируем конфиг: vi /etc/config/network Так как в моей домашней сети устройства получают адреса от роутера по DHCP, приводим конфиг примерно к такому виду: config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
option proto dhcp Применяем настройки сети: /etc/init.d/network reload Чтобы ВМ получала от роутера фиксированный IP адрес, добавляем MAC-адрес виртуального адаптера в список постоянных аренд в настройках DHCP сервера на роутере и присваиваем ему нужный IP.

Также отмечу, что я в настройках ВМ включил два сетевых интерфейса: один — для связи с домашней сетью и интернетом, второй — для других целей. Оба — в режиме сетевого моста. OpenWRT по умолчанию определила первый интерфейс (eth0) как lan со статическим адресом 192.168.1.1, второй (eth1) — как wan с получением адреса по DHCP. Таким образом доступ из виртуалки в домашнюю сеть и интернет получился сразу «из коробки». Однако по умолчанию фаервол OpenWRT запрещает подключение к ней по SSH и к вэб-интерфейсу по http «извне» — то есть через wan интерфейс. Но так как виртуалка будет находиться в моей домашней сети, я просто переназначил интерфейсы lan и wan для удобства работы: config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’option netmask ‘255.0.0.0’

config interface ‘wan’
option ifname ‘eth0’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘192.168.1.10’
option netmask ‘255.255.255.0’
option ip6assign ’60’

config interface ‘lan’
option ifname ‘eth1’
option proto ‘dhcp’

В VirtualBox версии 5.0.4 у меня наблюдался такой баг: виртуальные (гостевые) машины видели по сети роутер, друг друга, выходили в интернет, НО не видели хост-машину, так же как и хост-машина не видела гостевые! Баг вылечился обновлением VirtualBox до версии 5.0.6.

Расширение дискового пространства
Ну и теперь, когда у нашей ВМ есть выход в интернет, можно устанавливать все необходимые пакеты, например: opkg update
opkg install nano mc В скачанном образе OpenWRT корневой раздел размером около 48мБ. Этого вполне достаточно для установки пакетов первой необходимости и выполнения многих задач. Однако, если нам этого недостаточно, то увеличим виртуальный жёсткий диск. В VirtualBox вроде бы для этого есть специальный инструмент и можно в принципе воспользоваться им. Но я сделал иначе.
В настройках виртуальной машины подключим ещё один виртуальный жёсткий диск. Выбираем «Создать новый диск», затем задаём его название, выбираем нужный размер и формат хранения:

Загружаем нашу виртуалку и проверяем, что система увидела второй диск: ls -la /dev | grep sd
brw-r—r— 1 root root 8, 0 Oct 8 20:22 sda
brw-r—r— 1 root root 8, 1 Oct 8 20:22 sda1
brw-r—r— 1 root root 8, 2 Oct 8 20:22 sda2
brw-r—r— 1 root root 8, 1 Oct 8 20:22 sdb Видим, что второй диск определился как /dev/sdb. Теперь просто копируем первый диск на него утилитой dd: dd if=/dev/sda of=/dev/sdb Останавливаем ВМ, удаляем из неё первый диск и грузимся со второго, оставшегося (теперь он уже станет /dev/sda). Можем убедиться, что диск у нас теперь стал действительно такого размера, какой мы задали, например утилитой cfdisk: cfdisk /dev/sda Однако видим, что наш корневой раздел sda2 так и остался размером 48мБ, а остальное место на диске осталось неразмеченным. Поэтому качаем LiveCD с утилитой GParted, подключаем его к виртуальному CD-приводу нашей машины, и загружаем с него виртуалку. Ну а дальше — дело техники: запускаем GParted, выбираем раздел /dev/sda2 и растягиваем его на всё неразмеченное пространство диска. В конце жмём «применить» («Apply»), и выключаем машину. Вот и всё, теперь можно извлечь образ из виртуального CD-привода и снова загрузить виртуалку с жесткого диска. Проверяем результат: df -h
Filesystem Size Used Available Use% Mounted on
rootfs 7.9G 13.7M 7.9G 0% /
/dev/root 7.9G 13.7M 7.9G 0% /
tmpfs 122.6M 52.0K 122.6M 0% /tmp
tmpfs 512.0K 0 512.0K 0% /dev

Openwrt x86 установка на pc

Последняя версия: OpenWrt 19.07
В данной теме необходимо размещать изображения под спойлером

OpenWrt — встраиваемая операционная система, основанная на ядре Linux, и предназначенная, в первую очередь, для домашних маршрутизаторов. Основные компоненты включают в себя ядро Linux, util-linux, uClibc или musl и BusyBox. Исходный код открытый. Распространяется под лицензией GNU GPL

Проект LEDE разработан на основе линукса, встраиваемый мета-дистрибутив базирующийся на OpenWRT, ориентирован на широкий спектр беспроводных маршрутизаторов SOHO и не-сетевых устройств. “Linux Embedded Development Environment” (Встраиваемая среда разработки линукс).
LEDE отвернулся от материнского проекта в мае 2016 года, с целью продолжить разрабатывать лучшее программное обеспечение в открытой модели управления и поощрение новых разработчиков внести свой вклад и усилия в области развития.

  • Данная тема предназначена для обсуждения настроек, процесса установки на ваш маршрутизатор и всего что связано с прошивкой OpenWrt/LEDE.
  • В данной теме не обсуждают компиляцию из исходных кодов и пересборку, для этого есть тема Сборка OpenWrt/LEDE из исходных кодов
Читать еще:  Установка joomla на денвер

Настройка TFTP-сервера tftpd-hpa

Установим пакет tftpd-hpa:

содержащий настройки сервера. Приведём его к следующему виду:

В настройках указаны дополнительные опции:
create разрешает серверу создавать новые файлы,
ipv4 предписывает ему ожидать подключений только на адресах IPv4,
umask предписывает сбрасывать бит записи для группы и все биты доступа для остальных пользователей,
permissive предписывает не проводить никаких проверок прав доступа к файлу сверх производимых операционной системой.
Создадим каталог для tftp-сервера, дадим серверу доступ к каталогу:

sudo mkdir /var/tftp

sudo chown tftp:tftp /var/tftp

Можно также поменять домашний каталог пользователя tftp в файле /etc/passwd на /var/tftp.

Теперь просто прописываем нужные нам ip адреса через gnome network manager и все.

Осталось перезапустить демона, чтобы он начал работу с новым каталогом:

Сообщение отредактировал stp101 — 24.01.20, 22:20

Где найти прошивку для TP-Link TL-WR941N/ND v3.1

На данный момент

Мощность датчика на максимум. Перебрал все каналы. На телефон выдает почему то максимум 65.0 Mbit/s хотя он поддерживает 72 Mbit/s. Родная прошивка выдает ему всегда скорость 130. У DD-WRT тоже с этим проблемы!
Тем устройствам которым положено в режиме N на 40hz работать на всю катушку — присваивается ограниченная скорость. Пока что не могу понять в чем дело.

Сообщение отредактировал yarikx600 — 01.08.18, 19:19

Сообщение отредактировал stp101 — 01.08.18, 19:49

Убедитесь что в /etc/config/igmpproxy

config igmpproxy
option quickleave 1
# option verbose [0-2]

config phyint
option network wan
option zone wan
option direction upstream
list altnet 192.168.0.0/16
list altnet 172.16.0.0/12
list altnet 10.0.0.0/8

config phyint
option network lan
option zone lan
option direction downstream

А в /etc/config/firewall

config rule
option name ‘Allow-IPTV-IGMPPROXY’
option src ‘wan’
option proto ‘udp’
option dest_ip ‘224.0.0.0/4’
option target ‘ACCEPT’
option family ‘ipv4’
option dest ‘lan’

config rule
option name ‘Allow-IGMP’
option src ‘wan’
option proto ‘igmp’
option family ‘ipv4’
option target ‘ACCEPT’

Еще проблема может быть из-из появившейся поддержки IGMP snooping.

В разных темах замечал что люди интересовались как выключать wifi в OpenWrt в заданное время, собственно вот небольшая инструкция.
Есть два варианта.

Вариант 1 — через cron.

Для этого нужно перейти в Cистема -> Запланированные задания
И вписать нужную команду в это окно

Подробно расписано тут: DD-WRT — альтернативная прошивка (Пост stp101 #52504079) принцип одинаковый, так что будет работать и в OpenWrt

Вариант 2 — через веб интерфейс.
Это вот такая штука

Или через консоль, подключаемся по ssh и даем команды opkg update (обновляем список пакетов) и ставим opkg install luci-app-wifischedule (все остальные пакеты должны сами подтянуться, если не подтянутся, доустановите вручную opkg install wifischedule и opkg install luci luci-i18n-wifischedule-ru)
Вот и все 🙂 Теперь можно переходить в Сервисы -> Wi-Fi планировщик и настраивать расписание работы WIFI

Сообщение отредактировал stp101 — 06.09.18, 16:07

1) Подготовить USB-флешку. На флешке два раздела. Первый на 1 ГБ с файловой системой ext4. Второй — на всё оставшееся пространство тоже с файловой системой ext4.

2) Воткнуть флешку в роутер. Обновить список пакетов и установить необходимые:

3) В LuCi появится новый пункт меню, связанный с монтированием разделов накопителя (System → Mount Points). Там нужно нажать кнопку Generate Config, которая обнаружит разделы на подключённом накопителе — в Mount Points появятся разделы /dev/sda1 (1024 MB) и /dev/sda2

4) Нажать Edit возле sda1, включить Enable this mount, в качестве Mount point выбрать /overlay. Точно так же включить автомонтирование sda2 в качестве /data
В /data можно закачивать торренты и т. п. Это просто раздел под ваши нужды. У меня туда статистика использования трафика собирается, например.

5) Скопировать содержимое /overlay на флешку. В терминале:

6) Перезагрузить роутер (если всё получилось, то на странице Software должно прибавиться количество свободного места)

В случае проблем (допустим, накосячили с настройками так, что потеряли доступ к роутеру) вы всегда можете выключить роутер, воткнуть флешку в компьютер, поправить настройки.

Для любителей микрооптимизации: во-первых, читать это
Если желание оптимизировать ещё не пропало, можно заменить ext4 на F2FS (соответственно вместо kmod-fs-ext4 ставить kmod-fs-f2fs)
Если к использованию F2FS вы не готовы, а желание сэкономить ресурс флешки сильнее страха приключений на пятую точку, то:
— в п.1 после создания на флешке разделов выполнить в терминале:

Сообщение отредактировал Dart Raiden — 08.04.19, 22:43

Скрипт, который автоматически выполняет все необходимые действия. Если вы хотите сделать всё то же самое вручную, то читайте дальше.

Предварительные требования:
— прошита OpenWrt 18.06
— установлен веб-интерфейс LuCi
— роутер имеет доступ в Интернет

1) Обновить список пакетов (System → Software → Update lists), установить OpenVPN:

Впрочем, будет работать и openvpn-openssl. Если вы используете что-то более ранее, чем OpenWrt 18.06, то жизненно необходимо установить openvpn-openssl вместо openvpn-mbedtls.

2) Скачать файл конфигурации, положить .ovpn в /etc/openvpn
Я не буду подробно описывать процесс перемещения файлов в файловую систему роутера, вы можете воспользоваться WinSCP, SFTP-плагином для Total Commander (плагин умеет работать и по SCP), либо прямо из консоли с помощью wget и unzip, способов много.

Отредактировать этот файл, дописав куда-нибудь в его середину строку:

config openvpn antizapret

option enabled 1
option config /etc/openvpn/antizapret-tcp.ovpn

(опять же, способ редактирования конфига оставлен на усмотрение читателя: одному удобно через vi, другому через тот же WinSCP). antizapret-tcp.ovpn — это файл, который вы на прошлом шаге копировали. Если его название изменилось, то, соответственно, исправьте его и тут в конфиге.

4) Включить и запустить VPN (System → Startup). Проверить, что всё запустилось корректно. В Status → System Log будет примерно следующее:

5) Создать новый интерфейс (Network → Interfaces → Add new interface):
Name of the new interface: antizapret
Protocol of the new interface: unmanaged
Cover the following interface: Ethernet Adapter: «tun0»
Advanced settings → Bring up on boot
Firewall Settings → Create: → antizapret
Save and Apply

6) Настроить зону файерволла antizapret (Network → Firewall → antizapret → Edit):
Input: reject
Включить Masquerading и MSS clamping
Allow forward from source zones: lan
Save and Apply

7) Исправить /etc/config/dhcp:
значение

изменить с 1 на 0

8) Указать DNS-сервер, который будет использоваться, если подключение к VPN-серверу разорвано:
в настройках обоих интерфейсов WAN и WAN6 (Network → Interfaces) отключить Use DNS servers advertised by peer на вкладке Advanced settings
в настройках интерфейса WAN в поле Use custom DNS servers вписать адрес 1.1.1.1
Save and Apply

На сообщения «WARNING: this configuration may cache passwords in memory» в журнале внимания обращать не нужно, это неактуально, потому что паролей у нас нет. Если напрягает, можете добавить в файл конфигурации строчку

Плюсы:
— через VPN идёт лишь трафик до заблокированных доменов, остальной трафик идёт «напрямую» (нет потери скорости, у вас не меняется IP)
— следствие из предыдущего: трафик небольшой и поддержание бесплатного сервиса не бьёт по карману владельца

Скрипт, который автоматически выполняет все необходимые действия. Если вы хотите сделать всё то же самое вручную, то читайте дальше.

Читать еще:  Установка второго жесткого диска на компьютер

Предварительные требования:
— прошита OpenWrt 18.06
— установлен веб-интерфейс LuCi
— роутер имеет доступ в Интернет

1) Обновить список пакетов (System → Software → Update lists), установить OpenVPN, собранный с поддержкой mbed TLS:

Впрочем, будет работать и openvpn-openssl. Если вы используете что-то более ранее, чем OpenWrt 18.06, то жизненно необходимо установить openvpn-openssl вместо openvpn-mbedtls.

2) Скачать файл конфигурации, положить .ovpn в /etc/openvpn
Я не буду подробно описывать процесс перемещения файлов в файловую систему роутера, вы можете воспользоваться WinSCP, SFTP-плагином для Total Commander (плагин умеет работать и по SCP), либо прямо из консоли с помощью wget и unzip, способов много.

3) Заменить содержимое /etc/config/openvpn на:

config openvpn zaborona

option enabled 1
option config /etc/openvpn/zaborona-help.ovpn

(опять же, способ редактирования конфига оставлен на усмотрение читателя: одному удобно через vi, другому через тот же WinSCP). zaborona-help.ovpn — это файл, который вы на прошлом шаге копировали. Если его название изменилось, то, соответственно, исправьте его и тут в конфиге.

4) Включить и запустить VPN (System → Startup). Проверить, что всё запустилось корректно. В Status → System Log будет примерно следующее:

5) Создать новый интерфейс (Network → Interfaces → Add new interface):
Name of the new interface: zaborona
Protocol of the new interface: unmanaged
Cover the following interface: Ethernet Adapter: «tun0»
Advanced settings → Bring up on boot
Firewall Settings → Create: → zaborona
Save and Apply

6) Настроить зону файерволла zaborona (Network → Firewall → zaborona → Edit):
Input: reject
Включить Masquerading и MSS clamping
Allow forward from source zones: lan
Save and Apply

7) Если у вас пропал доступ в Интернет после этого пункта, не делайте его. В настройках интерфейса «WAN» (Network → Interfaces) отключить Use DNS servers advertised by peer на вкладке Advanced settings. В Use custom DNS servers вписать адрес 74.82.42.42. Нажать рядом «+», во вторую появившуюся строку вписать адрес 77.88.8.8. Save and Apply.

В настройках интерфейса «WAN6» (Network → Interfaces) отключить Use DNS servers advertised by peer на вкладке Advanced settings. В Use custom DNS servers вписать адрес 2001:4860:4860::8888. Нажать рядом «+», во вторую появившуюся строку вписать адрес 2001:4860:4860::8844. Save and Apply.

На сообщения «WARNING: this configuration may cache passwords in memory» в журнале внимания обращать не нужно, это неактуально, потому что паролей у нас нет. Если напрягает, можете добавить в файл конфигурации строчку

Плюсы:
— через VPN идёт лишь трафик до заблокированных доменов, остальной трафик идёт «напрямую» (нет потери скорости, у вас не меняется IP)
— следствие из предыдущего: трафик небольшой и поддержание бесплатного сервиса не бьёт по карману владельца

1) задать пароль администратора (через LuCI)

2) в разделе System → Administration включить Dropbear на интерфейсе «lan» (если включить на «wan», то он будет доступен всему интернету (если у вас белый IP), вскоре его начнут подбирать трудолюбивые китайцы. Поэтому, не вешайте на «wan»).

3) с помощью WinSCP подключиться со следующими параметрами:
Host name: 192.168.1.1
Login: root
Password: пароль_который_вы_установили_на_шаге_1

Получаете обычный 2-панельный файловый менеджер, с помощью которого можно перетаскивать файлы с ПК на роутер и обратно, а также править файлы на роутере).

1) задать пароль администратора (через LuCI)

2) в разделе System → Administration включить Dropbear на интерфейсе «lan» (если включить на «wan», то он будет доступен всему интернету (если у вас белый IP), вскоре его начнут подбирать трудолюбивые китайцы. Поэтому, не вешайте на «wan»).

3) с помощью SFTP-плагина для TC/DC (этот плагин, вопреки своему названию, умеет работать и по SCP) подключиться со следующими параметрами:
Connect to: 192.168.1.1
User name: root
Password: пароль_который_вы_установили_на_шаге_1

Если вы создаёте или редактируете файл в Windows, а затем копируете его на роутер, то перед копированием убедитесь, что переносы строк в файле UNIX-овские, а не Windows-овские! Для этого достаточно открыть файл в Notepad++ и в статусной строке внизу справа найти «Unix (LF)». Если там «Windows (CR LF)», то щёлкните правой кнопкой по надписи, выберите «Unix (LF)» и сохраните файл. Всё это нужно повторять после каждого редактирования, поэтому сначала редактируете как душе угодно, а затем уже проверяете переносы и заливаете на роутер.

Сообщение отредактировал Dart Raiden — 10.12.19, 17:19

Краткая инструкция по сборке OpenWRT

Напоминаем, что попытки повторить действия автора могут привести к потере гарантии на оборудование и даже к выходу его из строя. Материал приведен исключительно в ознакомительных целях. Если же вы собираетесь воспроизводить действия, описанные ниже, настоятельно советуем внимательно прочитать статью до конца хотя бы один раз. Редакция 3DNews не несет никакой ответственности за любые возможные последствия.

Создание собственной версии альтернативной прошивки полезно лишь в том случае, когда вас не устраивает функциональность имеющихся сборок — отсутствуют необходимые компоненты, а вместо них есть что-то совершенно ненужное. При этом объём памяти в роутере относительно невелик, а установить дополнительное ПО на внешний накопитель не всегда возможно. В принципе, ничего сложного в создании своей прошивки нет. Для OpenWRT есть утилита Image Generator, которая как раз таки может удалять или добавлять пакеты программ в уже имеющуюся сборку. Можно воспользоваться ей, а можно пойти по другому пути — скомпилировать свою прошивку с блек-джеком и. ну, вы поняли. Общее описание процесса можно найти в вики проекта.

Итак, нам понадобится компьютер с Linux/*BSD/Mac OS на борту, порядка пяти гигабайт свободного места на жёстком диске и немножечко терпения. Собирать прошивку в виртуальной машине с подходящей ОС крайне не рекомендуется, так как процесс компиляции в этом случае может излишне затянуться. В качестве примера рассмотрим работу в Ubuntu 11.10. Первым делом надо установить дополнительные утилиты и библиотеки, которые потребуются в процессе сборки. Для других ОС и дистрибутивов список нужного ПО можно посмотреть здесь. Минимально необходимый набор в нашем случае ставится такой командой.

Теперь надо создать рабочую папку, куда будут сохранены исходные тексты прошивки, её настройки, готовые образы и так далее. В пути до этой директории не должно быть пробелов. После создания каталога скачиваем в него исходные тексты OpenWRT.

Тут есть два варианта — либо взять стабильную версию, которая хорошо протестирована и надёжна до определённой степени, либо воспользоваться версией для разработчиков, в которой имеется немало новых возможностей, но вместе с тем получить ненулевую вероятность падений прошивки на ровном месте. Текущий релиз называется Backfire, а тестовая версия всегда находится в trunk. Выполните одну из приведённых ниже команд скачивания исходников из SVN-репозитория и перейдите в соответствующую папку.

В файле feeds.conf.default находится список репозиториев с дополнительными пакетами программ. Если это необходимо, отредактируйте его. Раскомментируйте (уберите # в начале строки) пункты в списке или добавьте сторонние адреса фидов для какого-то специфичного ПО. Нам как минимум пригодится стандартный набор пакетов и веб-интерфейс LuCI (можно выбрать другой или оставить настройки по умолчанию), поэтому в этот файл можно вообще не лезть, оставив всё по умолчанию, а сразу же обновить списки пакетов.

Приступим к самому интересному — наполнению прошивки компонентами. Первым делом для тестовой сборки установим веб-интерфейс LuCI, чтобы лишний раз не настраивать роутер из консоли. Остальные программы ищутся тем же скриптом с параметром search и ключевым словом после него. В выводе будут имена пакетов с кратким описанием. Для установки используем ту же утилиту с параметром install. Все зависимости будут автоматически разрешены и недостающие пакеты, если таковые нужны выбранному пользователем компоненту, будут также установлены.

Читать еще:  Установка grub на флешку

Для некоторых программ, возможно, захочется или придётся создать конфигурационные файлы. Для этого помещают их в каталог /files/etc/config, который надо создать в папке с исходниками. Вообще любые файлы из директории /files будут включены в прошивку. После этого можно переходить непосредственно к сборке. Выполним в консоли следующую команду.

Здесь переходим к пункту Target System (Enter) и выбираем платформу, для которой будет собрана прошивка. В списке совместимых устройств найдите вашу модель и посмотрите, какое у неё «железо». Для начала рекомендуется «потренироваться на кошках», то есть сделать x86-сборку с необходимым набором пакетов (учтите, что не для всех пакетов это удастся), а затем запустить её в виртуальной машине. А пока выходим в главное меню (Esc) и нажимаем Exit, не забывая сохранить новую конфигурацию. Чтобы получить базовые настройки для прошивки выполняем ещё одну команду.

Возвращаемся в главное меню и в Target Profile ищем свой роутер. Обратите внимание, что в некоторых моделях от версии к версии аппаратная начинка может заметно отличаться. Постарайтесь ничего не перепутать, а то в худшем случае вы получите «кирпич» вместо устройства. Если вы решили потестировать x86-сборку, то в Target Images отметьте пункты ramdisk и iso — на выходе получится загрузочный iso-образ.

А вот теперь самое муторное — ручной выбор необходимых компонентов. Установленные ранее пакеты надо включить в саму сборку, для чего придётся пройтись почти по всем разделам настроек. Для установки компонента перейдите к нему и нажмите пробел для его выбора. * означает, что он будет «вшит» в ядро, а M указывает на создание отдельного подгружаемого модуля. В ряде случаев активация компонента открывает доступ к дополнительным настройкам, связанным с ним.

В разделах Base system и Libraries находятся базовые программы и библиотеки. В Network и IPv6 помещено всё, что связано с работой в сети — Bittorrent- и VPN-клиенты, различные сервера, вспомогательные утилиты и многое другое.

В разделе LuCI настраиваются параметры веб-интерфейса, так как в качестве примера для x86-сборки был выбран именно он. Во-первых, его надо включить в Collections, а в Modules выбрать admin-core или admin-full. Подраздел Applications содержит модули для настройки тех или иных параметров роутера. Дополнительно надо установить локализации (Translations), поддержку настроек сетевых интерфейсов (Protocols) и базовые библиотеки (Libraries).

Раздел Kernel modules содержит в основном драйвера для «железа», файловых систем, различных подсистем и так далее. Здесь тоже полезно пробежаться по подразделам и включить, например, поддержку NTFS. К сожалению, какого-то универсального руководства к действию при настройке компонентов прошивки нет. Устанавливать дополнительные утилиты и библиотеки можно, но не стоит забывать о небольшом объёме накопителя в роутере. А вот удалять то, что по умолчанию было включено, надо с осторожностью. Ознакомьтесь хотя бы с краткой справкой по компоненту, нажав H, а ещё лучше погуглите.

После выбора всех нужных модулей и компонентов необходимо сохранить конфигурацию. Непосредственно перед сборкой полезно выполнить ещё одну команду, которая покажет недостающие утилиты или библиотеки. Их надо будет доустановить с помощью apt-get install или поискать пакеты, в которых они содержатся, и тоже установить.

Процесс сборки запускается очень простой командой:

Сборка прошивки длится довольно долго. Чем больше вы «напихали» в неё, тем дольше придётся ждать. Обладатели многоядерных процессоров могут чуть облегчить свою участь, добавив к команде make параметр -j x, где x=число ядер+1. На тестовой машине с CPU AMD Phenom II X6 базовая x86-прошивка с небольшими дополнениями компилировалась в несколько потоков примерно 10-15 минут. Впрочем, иногда использование нескольких процессорных ядер может привести к ошибке во время сборки.

Openwrt x86 установка на pc

Первым делом идем на сайт 4MLinux и скачиваем дистрибутив, почему именно 4MLinux? Ответ прост нам нужна live версия линукса, т.е. подойдет абсолютно любой дистрибутив, но 4MLinux обладаем очевидным плюсом – размер дистрибутва, а т.к. после установки он не понадобиться можно будет отложить его обратно на “полку”)

Далее нам нужно создать новую виртуальную машину (ВМ) в hyper-v, название машины пишем на свое усмотрение, главные параметры это поколение, нужно выбрать 1 поколение.

Выделяем количество ОЗУ под нашу машину, я выделю 2Гб = 2048Мб, т.к. 4MLinux не запускается на виртуальной машине с 1Гб, в принципе если это вам критично, можно будет после установки openwrt изменить объем на 1Гб..

Далее выбираем сетевой адаптер, через который будем раздавать интернет

Ну и наконец выделяем кол-во ПЗУ для виртуалки, в hyper-v минимальное значение = 1Гб, но сама openwrt требует не больше 100Мб, поэтому ставим 1Гб

Далее это очередная особенность дистрибутива 4MLinux, она не распознает сетевые интерфейсы hyper-v поэтому нужно добавить на эту виртуальную машину устаревший сетевой адаптер, опять же после установки openwrt его можно будет удалить из нашей ВМ

После этого запускаем нашу ВМ и ждем полной загрузки live дистрибутива, после того как он загрузился идем в терминал и первым делом задаем пароль для root пользователя, этот пароль будет использоваться как первоначальный пароль для входа в web интерфес openwrt.

После этого идем на официальный сайт openwrt, заходим раздел для x86 и далее в раздел x64, если вы хотите использовать x64 разрядную openwrt, и копируем ссылку с нужного нам файла, он обычно называется combined-ext4.img.gz.

Возвращаемся обратно в наш live linux в терминал, и скачиваем файл по только что скопированной ссылке:

На данный момент на жестком диске ВМ нет ни каких разделов, т.к. мы загрузились с live дистрибутива, убедиться в этом можно введя в терминал команду:
fdisk -l

Внимание! lede-17.01.4-x86-64-combined-ext4.img.gz – этот файл может быть у вас другим, т.к. на момент написания статьи это была самая актуальная сборка openwrt!

далее распаковываем скаченный файл:
gunzip lede-17.01.4-x86-64-combined-ext4.img.gz

ну и наконец копируем разделы и файлы из скаченного нами .img файла на жесткий диск ВМ
dd if=lede-17.01.4-x86-64-combined-ext4.img of=/dev/sda bs=1M count=1024

Параметры:
if: указывает на источник, т.е. на то, откуда копируем. Указывается файл, который может быть как обычным файлом, так и файлом устройства.
of: указывает на файл назначения. То же самое, писать можем как в обычный файл, так и напрямую в устройство.
bs: количество байт, которые будут записаны за раз. Можно представлять этот аргумент как размер куска данные, которые будут записаны или прочитаны, а количество кусков регулируется уже следующим параметром.
count: как раз то число, которое указывает: сколько кусочков будет скопировано.

Теперь если посмотреть разделы вы увидите, загрузочный и основной разделы на диске /dev/sda, после этого можно перезагрузить ВМ предварительно изъяв из виртуального dvd-rom образ с live linux дистрибутивом!
reboot

Вот и все установка завершена, после перезагрузки вы увидите приветствие openwrt, далее производите настройки уже виртуального маршрутизатора на свое усмотрение! =)

Чтоб локализовать LuCI на русский язык, ставим пакет:
opkg luci-i18n-base-ru
либо ищем его в самой LuCI, после установки страница браузера автоматически перезагрузится и у Вас будет полностью переведенный интерфейс!

Смотрите видео с описанием настройки, так же не забудьте подписаться на мой youtube канал! =) Еще будет много интересной и полезной информации!)

Ты знаешь, что такое безумие? Безумие — это точное повторение одного и того же действия, раз за разом, в надежде на изменение.

Ссылка на основную публикацию
Adblock
detector