Установка pyqt5 Windows zhitsoboy.ru

Установка pyqt5 Windows

Введение в PyQt5 [Урок 1]

Это введение к руководству по PyQt5. Назначение этого руководства – дать вам представление об возможностях PyQt5.

Руководство было разработано и протестировано на Linux.

PyQt5 реализован как комплект Python-модулей. Он включает в себя около 620 классов и 6000 функций и методов. Это мульти-платформенный инструментарий, который запускается на большинстве операционных систем, среди которых Unix, Windows и MacOS. PyQt5 реализован под двумя лицензиями. Разработчики могут выбрать между GPL и коммерческой лицензией.

Установка PyQt5

Для пользователей Linux дистрибутивов (Ubuntu, Debian, LinuxMint. ) прописать команду в терминал.

Классы PyQt5 разделены на несколько модулей, включая следующие:

  • QtCore
  • QtGui
  • QtWidgets
  • QtMultimedia
  • QtBluetooth
  • QtNetwork
  • QtPositioning
  • Enginio
  • QtWebSockets
  • QtWebKit
  • QtWebKitWidgets
  • QtXml
  • QtSvg
  • QtSql
  • QtTest

— Модуль QtCore содержит ядро с неграфической функциональностью. Этот модуль используется для работы с временем, файлами, папками, различными типами файлов, потоками, адресами URL, MIME-типами и процессами.

QtGui содержит классы для интеграции систем окон, обработки событий, 2D-графики, базовой обработки изображений, шрифтов и текста.

— Модуль QtWidgets содержит классы, которые обеспечивают набор UI-элементов для создания классических пользовательских интерфейсов.

QtMultimedia содержит классы для управления мультимедиа-содержимым, а также API для доступа к камере или функциональности радио.

— Модуль QtBluetooth содержит классы для поиска устройств, соединения и взаимодействия с ними.

— Модуль QtNetwork содержит классы для сетевого программирования. Эти классы облегчают работу с клиентами и серверами TCP/IP и UDP, делая сетевое программирование более легким и адаптивным.

QtPositioning содержит классы для определения местоположения с использованием всевозможных источников, таких как спутники, Wi-Fi или текстовые файлы.

— Модуль Enginio реализует клиентскую библиотеку для организации доступа к облачным сервисам Qt – Manaded Application Runtime.

— Модуль QtWebSockets содержит классы, которые реализуют протокол WebSocket.

QtWebKit содержит классы для реализации веб-браузера, основанного на библиотеке WebKit2.

— Модуль QtWebKitWidgets содержит классы для WebKit1, основанные на реализации веб-браузера, для использования в приложениях, базирующихся на QtWidgets.

QtXml содержит классы для работы с XML файлами. Этот модуль предоставляет реализацию сразу для двух API: SAX и DOM.

— Модуль QtSvg содержит классы для отображения содержимого SVG-файлов. Scalable Vector Graphics (SVG) – это язык для описания двумерной графики и графических приложений в XML.

— Модуль QtSql предоставляет классы для работы с базами данных.

QtTest содержит функции, которые дают возможность модульного тестирования PyQt-приложений.

Различия PyQt4 и PyQt5

  • Модули Python были реорганизованы. Некоторые модули были исключены (QtScript), другие были разделены на субмодули (QtGui, QtWebKit).
  • Новые модули представлены в виде QtBluetooth, QtPositioning или Enginio.
  • PyQt5 поддерживает только новый стиль обработки сигналов и слотов. Вызовы вида SIGNAL() или SLOT() больше не поддерживаются.
  • PyQt5 не поддерживает части Qt API, которые помечены как устаревшие в Qt v5.0.

Один из наиболее видимых особенностей – неиспользование точек с запяток и скобок. Взамен используются отступы. В настоящее время существует две главных ветви Python: Python 2.x и Python 3.x. Python 3.x прерывает обратную совместимость с предыдущими релизами Python. Это позволило исправить некоторые недостатки языка и сделать его более чистым. Самая последняя версия Python 2.x – 2.7.9, а Python 3.x – 3.4.2. Python поддерживается большой группой волонтёров со всего мира. Этот язык является программным обеспечением с открытым исходным кодом. Python – идеальный старт для тех, кто хочет изучать программирование.

Это руководство использует версию Python 3.x.

Инструментарий Python

Продолжение: Первые программы на PyQt5 [Урок 2]

Недавно начал осваивать Python, захотелось установить PyQt5, хотя понимаю, что возможно рановато мне ещё, нужно как следует изучить сам язык. Но тем не менее, хотелось бы пока хоть научится устанавливать разный инструментарий. Так вот, на Windows поставить Python и PyQt5 оказалось просто, а вот на линукс и конкретно на Linux Mint никак не ставится PyQt5. В менеджере программ его нет, менеджер пакетов Synaptic выдаёт несколько десятков пакетов с названием PyQt5 и непонятно что из этого устанавливать. Я прбовал устанавливать все, но PyQt5 среди установленных прграмм так и не появился. Пробовал скачивать дистрибутив PyQt5 под линукс с оф.сайта в архиве tar.gz, распаковывал, собирал его, но при установке выдаёт кучу разных ошибок.

На разных ресурсах совершенно противоречивые и взаимоисклучающие инструкции касательно этой темы и ни одна из них не работает — опять выдаёт ошибки при установке.

Несколько раз сносил-переустанавливать свой линукс, прописывал в терминале вот это:

sudo apt-get install python3-pyqt5 pyqt5-dev-tools

что-то ставится, но куда? После этого PyQt5 опять не видно в установленных программах, невозможно запустить pyqt designer, как в виндовс так как его нигде нет.

Может кто знает, что я делаю не так? И возможно ли в линукс запускать PyQt5 так же как и на виндовс, или же он тут запускается только из консоли какой-то командой? Может быть я его уже всё-таки установил и прсто не знаю как запустить?

Общее правило: если пакет встал, но как-то непонятно, можно проверить, что и куда он расставил (в консоли):

user:host% rpm -ql python3-pyqt5

Это выйдет длинный список всех файлов, поставленных данным пакетом. Тут уже можно смотреть бинарники (` | grep bin`), мануалы (` | grep man`) и прочее (` | grep html` для документации в данном случае).

А для питона в частности лучше посмотреть в модулях (опять же в консоли):

Если в вывалившемся списке есть PyQt5, то все в норме, можно работать. Если нет — то согласно пункту первому проверяем, что он вообще предоставляет, этот пакет. Может, пару примеров и все.

переходите на Windows ! И ,да,будет вам щястя 🙂 !

PyQt5 — модуль(бібліотека) яку імпортуе python. В списку програм її видно не буде, а Qt designer — це окрема програма не залежна від PyQT.

Как установить PyQt5 на Windows?

Когда я пытаюсь установить PyQt5 на Windows с помощью команды

Я получаю эту ошибку:

Я получил pyQt5 от PyQt5 загрузки .

Как я могу установить PyQt5?

Обновление:

Я установил Qt 5.0.2 for Windows 64-bit (VS 2012, 500 MB) со страницы загрузки Qt и теперь у меня есть эта ошибка:

И когда я выполняю команду python configure.py —verbose :

Я добавил C:Program Files (x86)Microsoft Visual Studio 11.0VCbin (содержит nmake.exe ) к PATH и получил эту ошибку:

11 Ответов

В основном я использую следующую команду под cmd

И это работает без проблем!

Самый простой способ установить PyQt — это просто использовать установщик (ссылка в вашем ответе, шаг #5). если вы устанавливаете python 3.3, установщик автоматически добавит все дополнения PyQt5 к этой установке python. Вам не нужно делать какие-либо компиляции (не: программы nmake, программы nmake, установить, настроить python).

Все параметры сборки доступны, если вам нужна пользовательская установка (например, с использованием другой версии python, где нет установщика, предоставляемого riverbank computing).

Если вам действительно нужно скомпилировать свою собственную версию PyQt5, шаги (как вы уже нашли) находятся здесь , но предположим, что у вас есть python и компилятор, установленный и в вашем пути. Установленные и на вашем пути были там, где вы, кажется, столкнулись с неприятностями. Я бы рекомендовал использовать версию установщика, но сначала вам нужно установить python 3.3 .

Сначала попробуйте сделать это в окне Windows cmd:

Если это удастся, то будет выглядеть примерно так:

Если это не сработало, вы можете попробовать эту ссылку из SourceForge.

Как найти установщик, который подходит именно вам?

Во-первых, определите, какая версия Python у вас есть и есть ли у вас 32-разрядная или 64-разрядная Python. Затем откройте один из каталогов. Я нахожусь на 64-битной версии Python 3.5, поэтому я ищу .exe с этими спецификациями. Когда вы откроете каталог на SourceForge, вы увидите некоторые каталоги с ONLY .zip или .tar.gz . Это не то, что ты ищешь. Хорошее указание на то, какой каталог вы должны щелкнуть, дает столбец «Downloads/Week». Я открою каталог PyQt-5.6 в своем кейсе.

Здесь мы замечаем некоторые файлы .exe:

Я знаю, что это Python 3.5 на Py3.5 в имени файла. Я также ищу 64-битную версию, поэтому я скачаю PyQt5-5.6-gpl-Py3.5-Qt5.6.0-x64-2.exe . Окончательный ответ!

Примечание: Если вы попытаетесь установить версию, которая не совместима с вашей системой, сразу после запуска появится диалоговое окно .exe. Это признак того, что вы выбрали не тот вариант. Я не пытаюсь говорить как дбаг. Я делал это несколько раз!

Чтобы проверить успешную установку, в вашем интерпретаторе Python попробуйте импортировать:

Я нашел частичное решение.

Шаги по установке pyQt5 (с VS 2012) на Windows:

1) Установите двоичный файл Qt 5.0.2 for Windows 64-bit (VS 2012, 500 MB) отсюда .

2) получить sip-4.14.7 (моментальный снимок разработки) отсюда .

3) извлеките файл и откройте Developer Command Prompt for VS2012 .

4) выполните эти команды (в папке sip):

5) получите pyQt5 отсюда .

6) извлеките файл и откройте VS2012 x64 Native Tools Command Prompt .

7) выполните эти команды:

UPDATE: при выполнении этих команд ниже не работает:

Решение: я попробую использовать pyQt4 с Qt5. потому что pyQt5 находится в разработке и еще не имеет поддержки/документации.

Один из самых простых (вероятно, самый простой) способов установки site-пакетов, таких как PyQt5, — это установка одной из версий Anaconda. Вы можете просто установить многие из пакетов сайта, установив его. Список доступных пакетов сайта с версиями Anaconda можно посмотреть здесь .

  1. Скачать Anaconda3 или Anaconda2
  2. Установить его.
  3. Добавьте путь PyQt5 внутри установки Anaconda в переменные системного окружения.
  1. Он готов к использованию.

Я новичок в оба Python и PyQt5. Я попытался использовать pip, но у меня возникли проблемы с ним, используя машину Windows. Если у вас есть версия Python 3.4 или выше, то pip установлен и готов к использованию примерно так:

Это, конечно, при условии, что путь к исполняемому файлу Python находится в переменной окружения PATH. В противном случае включите полный путь к исполняемому файлу Python (вы можете ввести where python в командное окно, чтобы найти его), как:

Другая команда под cmd -это:

Если вы используете Windows 10, если вы используете

в командной строке он должен скачать нормально. В зависимости от версии Python или Windows иногда python -m pip install pyqt5 не принимается, поэтому вы должны использовать py вместо этого. pip-это хороший способ загрузить много вещей, поэтому я бы рекомендовал это.

Если вы используете canopy, используйте диспетчер пакетов для установки qt (и / или pyqt)

Вы можете легко установить его с помощью Anaconda. Сначала установите Anaconda или Miniconda на вашей системе (скачать здесь ), а затем установите pyqt следующим образом:

Он работает для обеих версий python (2 и 3).

Чтобы установить версию GPL для PyQt5, выполните команду (см. Проект PyQt5 ):

Это позволит установить колесо Python для вашей платформы и вашей версии Python (при условии, что оба они поддерживаются ).

(Колесо будет автоматически загружено из индекса пакета Python.)

Колесо PyQt5 включает необходимые части версии LGPL Qt . Нет необходимости устанавливать Qt самостоятельно .

(Необходимый sip упакован как отдельное колесо и будет загружен и установлен автоматически .)

Примечание :

Если вы получаете сообщение об ошибке, говорящее что-то вроде

тогда вы, вероятно, используете неподдерживаемую версию Python.

Похожие вопросы:

Я портирую приложение Python 2, которое использует PyQt5 из Linux в Windows. Вопрос : Как установить PyQt5 на Windows? Что я уже пробовал: pip install PyQt5 терпит неудачу с: Downloading/unpacking.

Я установил PyQt5 с помощью командного окна Windows и pip3 install PyQt5 , как описано на странице загрузки , он был успешно установлен. но я не нашел PyQt Designer в меню Пуск Windows, поэтому я.

Я попытался установить PyQt5 на Windows 10 для python 3.4 с pip, используя этот код на cmd pip install pyqt5 он отвечает Collecting pyqt5 Using cached.

Я разработал программу с Python 3 64bit и PyQt5 на Debian 64bit (конечно, он работает на Linux и Windows 10 64bit). Проблема в том, что я не могу найти последнюю версию (если она вообще существует).

Мне нужно установить qscintilla . Я использую pip для этого: > pip install qscintilla PyQt5 автоматически обновляется до последней версии 5.8.2, и глоток обновления ‘4.19.2’. Я полагаю, что это.

ОК, когда я пытаюсь импортировать следующее С помощью PyCharm import sys from PyQt5.QtWidgets import QtGui, QtCore он генерирует эту ошибку при компиляции: ImportError: No module named ‘PyQt5’ В.

Я использую Windows 7 и Python 3.4 (32 бит). Я установил PyQt5 и продолжил просмотр учебных пособий по использованию модуля. Однако в учебнике вместо этого использовался PyQt4, и я столкнулся с.

Я отчаянно пытаюсь установить PyQt5 для python2.7 на моем Mac под управлением macOS Сьерра. Я пробовал бежать: brew install pyqt5 А также загрузка исходного кода и компиляция себя. Может ли.

Я пытаюсь использовать travis ci, чтобы вытащить запрос. И я использую python3 и pyqt5. Итак, я должен сделать линию установки .travis.yml. Но я не знаю, как сделать python3 и pyqt5 установить.

Я скачал PyQt5 исполняемый файл на Windows 7 для python 2.7 обе 64-битные версии. Устанавливается на C:Python27Libsite-packagesPyQt5 Я пытаюсь использовать приведенный выше код: from.

Как установить PyQt5 на Windows?

Когда я пытаюсь установить PyQt5 на Windows с помощью команды

Я получаю эту ошибку:

Я получил pyQt5 от PyQt5 загрузки .

Как я могу установить PyQt5?

Обновление:

Я установил Qt 5.0.2 for Windows 64-bit (VS 2012, 500 MB) со страницы загрузки Qt и теперь у меня есть эта ошибка:

И когда я выполняю команду python configure.py —verbose :

Я добавил C:Program Files (x86)Microsoft Visual Studio 11.0VCbin (содержит nmake.exe ) к PATH и получил эту ошибку:

11 Ответов

В основном я использую следующую команду под cmd

И это работает без проблем!

Самый простой способ установить PyQt — это просто использовать установщик (ссылка в вашем ответе, шаг #5). если вы устанавливаете python 3.3, установщик автоматически добавит все дополнения PyQt5 к этой установке python. Вам не нужно делать какие-либо компиляции (не: программы nmake, программы nmake, установить, настроить python).

Все параметры сборки доступны, если вам нужна пользовательская установка (например, с использованием другой версии python, где нет установщика, предоставляемого riverbank computing).

Если вам действительно нужно скомпилировать свою собственную версию PyQt5, шаги (как вы уже нашли) находятся здесь , но предположим, что у вас есть python и компилятор, установленный и в вашем пути. Установленные и на вашем пути были там, где вы, кажется, столкнулись с неприятностями. Я бы рекомендовал использовать версию установщика, но сначала вам нужно установить python 3.3 .

Сначала попробуйте сделать это в окне Windows cmd:

Если это удастся, то будет выглядеть примерно так:

Если это не сработало, вы можете попробовать эту ссылку из SourceForge.

Как найти установщик, который подходит именно вам?

Во-первых, определите, какая версия Python у вас есть и есть ли у вас 32-разрядная или 64-разрядная Python. Затем откройте один из каталогов. Я нахожусь на 64-битной версии Python 3.5, поэтому я ищу .exe с этими спецификациями. Когда вы откроете каталог на SourceForge, вы увидите некоторые каталоги с ONLY .zip или .tar.gz . Это не то, что ты ищешь. Хорошее указание на то, какой каталог вы должны щелкнуть, дает столбец «Downloads/Week». Я открою каталог PyQt-5.6 в своем кейсе.

Здесь мы замечаем некоторые файлы .exe:

Я знаю, что это Python 3.5 на Py3.5 в имени файла. Я также ищу 64-битную версию, поэтому я скачаю PyQt5-5.6-gpl-Py3.5-Qt5.6.0-x64-2.exe . Окончательный ответ!

Примечание: Если вы попытаетесь установить версию, которая не совместима с вашей системой, сразу после запуска появится диалоговое окно .exe. Это признак того, что вы выбрали не тот вариант. Я не пытаюсь говорить как дбаг. Я делал это несколько раз!

Чтобы проверить успешную установку, в вашем интерпретаторе Python попробуйте импортировать:

Я нашел частичное решение.

Шаги по установке pyQt5 (с VS 2012) на Windows:

1) Установите двоичный файл Qt 5.0.2 for Windows 64-bit (VS 2012, 500 MB) отсюда .

2) получить sip-4.14.7 (моментальный снимок разработки) отсюда .

3) извлеките файл и откройте Developer Command Prompt for VS2012 .

4) выполните эти команды (в папке sip):

5) получите pyQt5 отсюда .

6) извлеките файл и откройте VS2012 x64 Native Tools Command Prompt .

7) выполните эти команды:

UPDATE: при выполнении этих команд ниже не работает:

Решение: я попробую использовать pyQt4 с Qt5. потому что pyQt5 находится в разработке и еще не имеет поддержки/документации.

Один из самых простых (вероятно, самый простой) способов установки site-пакетов, таких как PyQt5, — это установка одной из версий Anaconda. Вы можете просто установить многие из пакетов сайта, установив его. Список доступных пакетов сайта с версиями Anaconda можно посмотреть здесь .

  1. Скачать Anaconda3 или Anaconda2
  2. Установить его.
  3. Добавьте путь PyQt5 внутри установки Anaconda в переменные системного окружения.
  1. Он готов к использованию.

Я новичок в оба Python и PyQt5. Я попытался использовать pip, но у меня возникли проблемы с ним, используя машину Windows. Если у вас есть версия Python 3.4 или выше, то pip установлен и готов к использованию примерно так:

Это, конечно, при условии, что путь к исполняемому файлу Python находится в переменной окружения PATH. В противном случае включите полный путь к исполняемому файлу Python (вы можете ввести where python в командное окно, чтобы найти его), как:

Другая команда под cmd -это:

Если вы используете Windows 10, если вы используете

в командной строке он должен скачать нормально. В зависимости от версии Python или Windows иногда python -m pip install pyqt5 не принимается, поэтому вы должны использовать py вместо этого. pip-это хороший способ загрузить много вещей, поэтому я бы рекомендовал это.

Если вы используете canopy, используйте диспетчер пакетов для установки qt (и / или pyqt)

Вы можете легко установить его с помощью Anaconda. Сначала установите Anaconda или Miniconda на вашей системе (скачать здесь ), а затем установите pyqt следующим образом:

Он работает для обеих версий python (2 и 3).

Чтобы установить версию GPL для PyQt5, выполните команду (см. Проект PyQt5 ):

Это позволит установить колесо Python для вашей платформы и вашей версии Python (при условии, что оба они поддерживаются ).

(Колесо будет автоматически загружено из индекса пакета Python.)

Колесо PyQt5 включает необходимые части версии LGPL Qt . Нет необходимости устанавливать Qt самостоятельно .

(Необходимый sip упакован как отдельное колесо и будет загружен и установлен автоматически .)

Примечание :

Если вы получаете сообщение об ошибке, говорящее что-то вроде

тогда вы, вероятно, используете неподдерживаемую версию Python.

Похожие вопросы:

Я портирую приложение Python 2, которое использует PyQt5 из Linux в Windows. Вопрос : Как установить PyQt5 на Windows? Что я уже пробовал: pip install PyQt5 терпит неудачу с: Downloading/unpacking.

Я установил PyQt5 с помощью командного окна Windows и pip3 install PyQt5 , как описано на странице загрузки , он был успешно установлен. но я не нашел PyQt Designer в меню Пуск Windows, поэтому я.

Я попытался установить PyQt5 на Windows 10 для python 3.4 с pip, используя этот код на cmd pip install pyqt5 он отвечает Collecting pyqt5 Using cached.

Я разработал программу с Python 3 64bit и PyQt5 на Debian 64bit (конечно, он работает на Linux и Windows 10 64bit). Проблема в том, что я не могу найти последнюю версию (если она вообще существует).

Мне нужно установить qscintilla . Я использую pip для этого: > pip install qscintilla PyQt5 автоматически обновляется до последней версии 5.8.2, и глоток обновления ‘4.19.2’. Я полагаю, что это.

ОК, когда я пытаюсь импортировать следующее С помощью PyCharm import sys from PyQt5.QtWidgets import QtGui, QtCore он генерирует эту ошибку при компиляции: ImportError: No module named ‘PyQt5’ В.

Я использую Windows 7 и Python 3.4 (32 бит). Я установил PyQt5 и продолжил просмотр учебных пособий по использованию модуля. Однако в учебнике вместо этого использовался PyQt4, и я столкнулся с.

Я отчаянно пытаюсь установить PyQt5 для python2.7 на моем Mac под управлением macOS Сьерра. Я пробовал бежать: brew install pyqt5 А также загрузка исходного кода и компиляция себя. Может ли.

Я пытаюсь использовать travis ci, чтобы вытащить запрос. И я использую python3 и pyqt5. Итак, я должен сделать линию установки .travis.yml. Но я не знаю, как сделать python3 и pyqt5 установить.

Я скачал PyQt5 исполняемый файл на Windows 7 для python 2.7 обе 64-битные версии. Устанавливается на C:Python27Libsite-packagesPyQt5 Я пытаюсь использовать приведенный выше код: from.

Как установить PyQt5 в Windows? — python

Когда я пытаюсь установить PyQt5 на Windows с помощью команды

Я получаю эту ошибку:

Я получил pyQt5 от PyQt5 Скачать.

Как я могу установить PyQt5?

Обновить:

Я установил Qt 5.0.2 for Windows 64-bit (VS 2012, 500 MB) со страницы загрузки Qt, и теперь у меня появляется эта ошибка:

И когда я выполняю команду python configure.py —verbose :

Я добавил C:Program Files (x86)Microsoft Visual Studio 11.0VCbin (содержит nmake.exe ) в PATH и получил эту ошибку:

  • 4
  • 11
  • 5 окт 2019 2019-10-05 21:20:18
  • Victor Lellis

11 ответов

Чтобы установить версию PyQt5 под GPL, запустите (см. Проект PyQt5):

Это установит колесо Python для вашей платформы и вашей версии Python (при условии, что оба поддерживаются).

(Колесо будет автоматически загружено из индекса пакетов Python.)

Колесо PyQt5 включает в себя необходимые части версии LGt Qt. Нет необходимости устанавливать Qt самостоятельно.

(Необходимый sip упакован как отдельное колесо и будет загружен и установлен автоматически.)

Примечание:

Если вы получаете сообщение об ошибке, говорящее что-то как

тогда вы, вероятно, используете неподдерживаемую версию Python.

  • 5 окт 2019 2019-10-05 21:20:22
  • MarianD

Если вы используете купол, используйте диспетчер пакетов для установки qt (и или pyqt)

  • 5 окт 2019 2019-10-05 21:20:21
  • Ivan_ug

Вы можете легко установить его с помощью Anaconda. Сначала установите Anaconda или Miniconda на вашу систему (скачайте с здесь), а затем установите pyqt следующим образом:

Он работает для обеих версий python (2 и 3).

  • 5 окт 2019 2019-10-05 21:20:21
  • Ali Mirzaei

Если вы используете Windows 10, если вы используете

в командной строке он должен скачать нормально. В зависимости от версии Python или Windows, иногда python -m pip install pyqt5 не принимается, поэтому вы должны использовать вместо него py. pip — это хороший способ загрузить много вещей, поэтому я бы порекомендовал это.

  • 5 окт 2019 2019-10-05 21:20:21
  • NotEvenTheRain

Другая команда под cmd :

  • 5 окт 2019 2019-10-05 21:20:21
  • Trigremm

Я новичок в Python и PyQt5. Я пытался использовать pip, но у меня были проблемы с ним на компьютере с Windows. Если у вас версия Python 3.4 или выше, pip установлен и готов к использованию следующим образом:

Это, конечно, при условии, что путь к исполняемому файлу Python находится в переменной среды PATH. В противном случае укажите полный путь к исполняемому файлу Python (вы можете указать, where python в командном окне, чтобы найти его), например:

  • 5 окт 2019 2019-10-05 21:20:20
  • Felipe Centeno

Один из самых (возможно, самый) самый простой способ установки пакетов сайта, таких как PyQt5, — это установка одной из версий Anaconda. Вы можете установить многие пакеты сайтов, установив их. Список доступных пакетов сайтов с версиями Anaconda можно проверить здесь.

  • Dowload Anaconda3 или Anaconda2
  • Установите его.
  • Добавьте путь PyQt5 в установку Anaconda к переменным System Environment.
  1. Он готов к использованию.
  • 5 окт 2019 2019-10-05 21:20:20
  • cengineer

Я нашел частичное решение.

Шаги по установке pyQt5 (с VS 2012) в Windows:

1) Установите двоичный файл Qt 5.0.2 for Windows 64-bit (VS 2012, 500 MB) из здесь.

2) Получите sip-4.14.7 (моментальный снимок разработки) из здесь.

3) Извлеките файл и откройте Developer Command Prompt for VS2012 .

4) Выполните эти команды (в папке sip):

5) Получите pyQt5 из здесь.

6) Извлеките файл и откройте VS2012 x64 Native Tools Command Prompt .

7) Выполните следующие команды:

UPDATE: При выполнении этих команд ниже не работает:

Решение: я попытаюсь использовать pyQt4 с Qt5. потому что pyQt5 находится в разработке и еще не имеет поддержки/документации.

  • 5 окт 2019 2019-10-05 21:20:20
  • Victor Lellis

Сначала попробуйте это в окне Windows cmd:

Если это будет успешным, оно будет выглядеть примерно так:

Если это не сработало, вы можете попробовать эту ссылку из SourceForge.

Как найти установщика, который подходит именно вам?

Сначала определите, какая у вас версия Python и есть ли у вас 32-разрядный или 64-разрядный Python. Затем откройте один из каталогов. Я на Python 3.5 64-бит, поэтому я ищу .exe с этими спецификациями. Когда вы открываете каталог в SourceForge, вы увидите некоторые каталоги с ТОЛЬКО .zip или .tar.gz. Это не то, что вы ищете. Хорошая индикация того, какой каталог вы должны щелкнуть, указывается столбцом «Загрузки/Неделя». В моем случае я открою каталог PyQt-5.6.

Здесь мы замечаем некоторые .exe файлы:

Я знаю, что это Python 3.5 на Py3.5 в имени файла. Я также ищу 64-битную версию, поэтому я загружу PyQt5-5.6-gpl-Py3.5-Qt5.6.0-x64-2.exe . Окончательный ответ!

Примечание. Если вы попытаетесь установить версию, несовместимую с вашей системой, диалоговое окно появится сразу после запуска .exe. Это указание на то, что вы выбрали неверный. Я не пытаюсь звучать как dbag. Я делал это несколько раз!

Чтобы проверить успешную установку, в интерпретаторе Python попробуйте импортировать:

Читать еще:  Установка второй операционной системы Linux
Ссылка на основную публикацию
Adblock
detector